Tamriel Foundry

Hook64 (Previously ESO Launcher)

Current Version: 1.4.8a

Website: Website

Download Hook64

If you are upgrading from versions prior to 1.4.7, you must overwrite all of the files for it to work properly.

Note: You need to install the following Microsoft files to run Hook64:

Microsoft .NET 4.6.2

Microsoft C++ Redistributable 2015 x86

Microsoft C++ Redistributable 2015 x64

If you want more detailed information or screenshots, please visit the website listed above.

About Sorien:

Sorien hasn't shared anything about themselves.

741 Replies
  1. #1

    Skreemin

    Member3 Posts

    Woohoo!! Thanks Sorien! Think you could link the ESO Launcher compatible SweetFX while you're at it?

  2. #2

    ZiggsRPG

    Member90 Posts

    Just from having messed around with the graphics options a lot I will say that the two biggest differences between the screenshots are that the gamma is turned down in the modded screenshots and the view distance is turned up. Not sure that you really need a mod to do that though.

  3. #3

    zzzleepyhead

    Member75 Posts
    ZiggsRPG wrote on September 29, 2014

    Just from having messed around with the graphics options a lot I will say that the two biggest differences between the screenshots are that the gamma is turned down in the modded screenshots and the view distance is turned up. Not sure that you really need a mod to do that though.

    It's not that at all, it's shaders and removing fog completely (in game max view distance is still limiting).  There's an assortment of other options as well that the mod offers.

  4. #4

    stealthbr

    Member9 Posts

    Thanks for this, Sorien. Like Skreemin, I would like to know where to download the ESO-compatible SweetFX.

    Also, if I one day decide to uninstall this graphics enhancer, do I simply delete the folder?

  5. #5

    Sorien

    Member247 Posts

    Sorry, I've been really busy... I've added the link to SweetFX for ESO to the initial post, and here's a link for it as well: SweetFX

    As for deleting it, yea you just delete the folder you extracted ESO Launcher to.

  6. #6

    Ramasurinen

    Member21 Posts

    Hi Sorien, hope you've been well. Thanks again for sticking with your launcher, it's just bloody awesome.

     

    Unfortunately it's also causing the odd crash I think. Ever since the 1.4 update I've been getting random exception error crashes in ESO, often when changing zones, logging in or out, or opening a door etc, but sometimes just when riding along. I removed all of my addons and it still happens. I deleted and rebuilt the shader cache as well, but that didn't help either. Also did a repair pass on ESO, but it didn't find any errors.

     

    So for the past couple of days I've been running ESO without the launcher and just using Cheatengine to change the FOV values, and it's been rock solid. I don't use any of the launcher's other features (no fog changes etc) just the FOV stuff. I also tried removing that framerate based level of detail changing script it comes with, thinking that might be the culprit, but the exception errors kept happening. I recently had a friend download the launcher to try it and he's already had two exception error crashes in two play sessions, though the rest of the time it seems to work fine for him. I'm using your latest one of course, 1.2.0.7. I also tried reinstalling the C++ redist and .NET 4.0 and both are up to date.

     

    So I'm out of ideas of things to try here. Do you have any thoughts?

     

    Has anyone else run across this problem at all lately?

     

    Also, if you are able, please do set up a paypal donor account. I would like to make a second donation for your continued efforts. :)

     

    Thanks very much Sorien!

  7. #7

    Sorien

    Member247 Posts

    Ill reactivate my account in the next week or two and try to see whats up... sorry that I can't get to it sooner. =/

  8. #8

    Ramasurinen

    Member21 Posts

    Hi Sorien. Thanks for the reply and for looking into it.

    Update 5 will be showing up in around 10 days I figure, so that would be a good time to have a look at the new stuff anyway, and maybe that update will solve the issue all on its own. Fingers crossed. :)

     

     

  9. #9

    Auldjohn

    Member140 Posts

    @Sorien,

    Update 5 is now on PTS and API 100010 (for Update 5) is on the ESO Forums and on ESOUI. I'll post a link to the API when you've re-ssubbed to ESO so you don't find a "dead link". TIA, my friend.

  10. #10

    Vizier

    Member2 Posts

    Just a heads-up Sorien

     

    Previous to the post 1.4 updates, ESO Launcher 1.2.0.7 was working well, and the various functions seemed to be working as intended.  When I launched ESO Launcher It would start with a popup that read "attach."  I would select yes and it launched flawlessly.  I'm not certain what was attached as I never had that with previous version of your mod, but after the post 1.4 updates that feature stopped and I noticed a distinct lessening of the effects to my game.  There is still an increase in the FOV but the overall look of the game is not what it was previous to the patches.

     

    Thanks again for your mod. I hope you are able to continue supporting it.

  11. #11

    Ramasurinen

    Member21 Posts

    Hi Sorien. Just a small addendum to the crashes I mentioned. They only seem to happen when I'm playing in windowed or maximized windowed mode.

     

    I've been using your launcher in "exclusive full screen" mode for two days now and it's been absolutely rock solid the whole time, and with some very very long play sessions, 6 or 7 hours at a time. In windowed mode I can expect an exception error crash within 1-2 hours at best usually. Odd stuff.

     

    Cheers.

     

  12. #12

    Ignotus

    Member3 Posts

    EDIT: Rebooting fixed it. I just hate rebooting so I didn't want to do it, but I didn't see any alternative so figured what the hell and tried it. I'll go ahead and leave this here though in case anyone is interested. Thanks! Oh, one last thing, is there a way to increase the distance that I can zoom out when in 3rd person?

    --------------------------------

    Hi, I just now signed up for the site. I created an account because I downloaded and tried ESO Launcher. I tried using the program and it crashed. I then tried launching eso.exe directly and it's now crashing too.

    Here is the error I get when eso.exe crashes:

    Problem signature:

    Problem Event Name:    BEX

    Application Name:    eso.exe

    Application Version:    1.0.0.1

    Application Timestamp:    5437245f

    Fault Module Name:    StackHash_0a9e

    Fault Module Version:    0.0.0.0

    Fault Module Timestamp:    00000000

    Exception Offset:    0084e9c6

    Exception Code:    c0000005

    Exception Data:    00000008

    OS Version:    6.1.7601.2.1.0.256.1

    Locale ID:    1033

    Additional Information 1:    0a9e

    Additional Information 2:    0a9e372d3b4ad19135b953a78882e789

    Additional Information 3:    0a9e

    Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

  13. #13

    Auldjohn

    Member140 Posts

    @Sorien,

    At one point you posted a readme for SweetFX, either in the old TF thread or on your former Mobi site.  I refreshed my download of SweetFX today from your link in this thread. Unfortunately the posted File Dropper SweetFX ZIP does not include the readme. I must have accidentally deleted the readme from my downloads folders.

    Please repost the SweetFX instructions or readme here in this new thread. I forgot where to put the SweetFX files and how to activate it in either ESO or  Skyrim. TIA!

    --Auldjohn, MobiPlus subscriber.

  14. #14

    Ramasurinen

    Member21 Posts

    Hi Sorien. It looks like the crashes I was experiencing with the launcher were not its fault, though it may have just been bringing them to light. It must have been an nvidia driver vs ESO 1.4 problem as updating to the newest beta drivers has fixed the exception errors completely. It was only happening when using the launcher, but maybe that was just pushing an already unstable game over the edge, dunno. Regardless it's been working perfectly for almost a week now, not a single error. Yay!

     

    Cheers.

  15. #15

    Vizier

    Member2 Posts

    Just wondering if the mod is still being supported.   ESO is pretty much unplayable for me without an altered FOV.  I see a decide lack of activity in this thread for what I would think is a very popular mod.

  16. #16

    Thumper

    Member7 Posts

    Looks like update 5 has gorfed the launcher again.  :( @Sorien

    I get the following error:

    There was an error modifying the game, the game will  be loaded normally.

    Patch Error #:3, Hook Error true

    Its like I have cataracts now. :(  If I look down my feet are foggy.  Ok, not quite, but close.

  17. #17

    xMovingTarget

    Member32 Posts

    Getting dizzy because the standard FoV ! Need update ;)

  18. #18

    Ariannona

    Member17 Posts

    Can confirm, newest patch brought Error code

     

    There was an error modifying the game, the game will  be loaded normally.

    Patch Error #:3, Hook Error true

  19. #19

    Sorien

    Member247 Posts

    Ill fix it later today... I haven't slept yet.

  20. #20

    Thumper

    Member7 Posts

    Thanks Sorien it is greatly appreciated.  IT would be financially appreciated if you had a method for me to do so. :)

Respond

Sorry, you must first log in or register for a Tamriel Foundry account before you may comment on articles!

Please respect the Tamriel Foundry Code of Conduct when commenting on articles.