Hook64 (Previously ESO Launcher)

  1. Profile Photo
    Sorien

    Adept

    Total Posts: 242

    Current Version: 1.4.8a
    Website: Website
    Download Hook64

    If you are upgrading from versions prior to 1.4.7, you must overwrite all of the files for it to work properly.

    Note: You need to install the following Microsoft files to run Hook64:
    Microsoft .NET 4.6.2
    Microsoft C++ Redistributable 2015 x86
    Microsoft C++ Redistributable 2015 x64

    If you want more detailed information or screenshots, please visit the website listed above.

    • This topic was modified 5 days, 8 hours ago by Profile photo of Sorien Sorien.
  2. Member Avatar
    Skreemin

    Scamp

    Total Posts: 3

    Woohoo!! Thanks Sorien! Think you could link the ESO Launcher compatible SweetFX while you’re at it?

  3. Profile Photo
    ZiggsRPG

    Journeyman

    Total Posts: 90

    Imperial Nightblade

    Just from having messed around with the graphics options a lot I will say that the two biggest differences between the screenshots are that the gamma is turned down in the modded screenshots and the view distance is turned up. Not sure that you really need a mod to do that though.

  4. Profile Photo
    zzzleepyhead

    Journeyman

    Total Posts: 75

    Altmer Sorcerer

    ZiggsRPG said on September 29, 2014 :

    Just from having messed around with the graphics options a lot I will say that the two biggest differences between the screenshots are that the gamma is turned down in the modded screenshots and the view distance is turned up. Not sure that you really need a mod to do that though.

    It’s not that at all, it’s shaders and removing fog completely (in game max view distance is still limiting).  There’s an assortment of other options as well that the mod offers.

  5. Member Avatar
    stealthbr

    Scamp

    Total Posts: 9

    Thanks for this, Sorien. Like Skreemin, I would like to know where to download the ESO-compatible SweetFX.

    Also, if I one day decide to uninstall this graphics enhancer, do I simply delete the folder?

    • This reply was modified 2 years, 8 months ago by Profile photo of stealthbr stealthbr.
  6. Profile Photo
    Sorien

    Adept

    Total Posts: 242

    Sorry, I’ve been really busy… I’ve added the link to SweetFX for ESO to the initial post, and here’s a link for it as well: SweetFX

    As for deleting it, yea you just delete the folder you extracted ESO Launcher to.

  7. Member Avatar
    Ramasurinen

    Novice

    Total Posts: 21

    Hi Sorien, hope you’ve been well. Thanks again for sticking with your launcher, it’s just bloody awesome.

     

    Unfortunately it’s also causing the odd crash I think. Ever since the 1.4 update I’ve been getting random exception error crashes in ESO, often when changing zones, logging in or out, or opening a door etc, but sometimes just when riding along. I removed all of my addons and it still happens. I deleted and rebuilt the shader cache as well, but that didn’t help either. Also did a repair pass on ESO, but it didn’t find any errors.

     

    So for the past couple of days I’ve been running ESO without the launcher and just using Cheatengine to change the FOV values, and it’s been rock solid. I don’t use any of the launcher’s other features (no fog changes etc) just the FOV stuff. I also tried removing that framerate based level of detail changing script it comes with, thinking that might be the culprit, but the exception errors kept happening. I recently had a friend download the launcher to try it and he’s already had two exception error crashes in two play sessions, though the rest of the time it seems to work fine for him. I’m using your latest one of course, 1.2.0.7. I also tried reinstalling the C++ redist and .NET 4.0 and both are up to date.

     

    So I’m out of ideas of things to try here. Do you have any thoughts?

     

    Has anyone else run across this problem at all lately?

     

    Also, if you are able, please do set up a paypal donor account. I would like to make a second donation for your continued efforts. :)

     

    Thanks very much Sorien!

    • This reply was modified 2 years, 8 months ago by Profile photo of Ramasurinen Ramasurinen.
  8. Profile Photo
    Sorien

    Adept

    Total Posts: 242

    Ill reactivate my account in the next week or two and try to see whats up… sorry that I can’t get to it sooner. =/

  9. Member Avatar
    Ramasurinen

    Novice

    Total Posts: 21

    Hi Sorien. Thanks for the reply and for looking into it.

    Update 5 will be showing up in around 10 days I figure, so that would be a good time to have a look at the new stuff anyway, and maybe that update will solve the issue all on its own. Fingers crossed. :)

     

     

  10. Profile Photo
    Auldjohn

    Adept

    Total Posts: 139

    Imperial Templar

    The Elder Sages Guild (TESG)

    @Sorien,

    Update 5 is now on PTS and API 100010 (for Update 5) is on the ESO Forums and on ESOUI. I’ll post a link to the API when you’ve re-ssubbed to ESO so you don’t find a “dead link”. TIA, my friend.

    • This reply was modified 2 years, 8 months ago by Profile photo of Auldjohn Auldjohn. Reason: Added ESOUI as API file source
  11. Profile Photo
    Vizier

    Scamp

    Total Posts: 2

    Just a heads-up Sorien

     

    Previous to the post 1.4 updates, ESO Launcher 1.2.0.7 was working well, and the various functions seemed to be working as intended.  When I launched ESO Launcher It would start with a popup that read “attach.”  I would select yes and it launched flawlessly.  I’m not certain what was attached as I never had that with previous version of your mod, but after the post 1.4 updates that feature stopped and I noticed a distinct lessening of the effects to my game.  There is still an increase in the FOV but the overall look of the game is not what it was previous to the patches.

     

    Thanks again for your mod. I hope you are able to continue supporting it.

    • This reply was modified 2 years, 8 months ago by Profile photo of Vizier Vizier.
  12. Member Avatar
    Ramasurinen

    Novice

    Total Posts: 21

    Hi Sorien. Just a small addendum to the crashes I mentioned. They only seem to happen when I’m playing in windowed or maximized windowed mode.

     

    I’ve been using your launcher in “exclusive full screen” mode for two days now and it’s been absolutely rock solid the whole time, and with some very very long play sessions, 6 or 7 hours at a time. In windowed mode I can expect an exception error crash within 1-2 hours at best usually. Odd stuff.

     

    Cheers.

     

  13. Profile Photo
    Ignotus

    Scamp

    Total Posts: 3

    EDIT: Rebooting fixed it. I just hate rebooting so I didn’t want to do it, but I didn’t see any alternative so figured what the hell and tried it. I’ll go ahead and leave this here though in case anyone is interested. Thanks! Oh, one last thing, is there a way to increase the distance that I can zoom out when in 3rd person?
    ——————————–
    Hi, I just now signed up for the site. I created an account because I downloaded and tried ESO Launcher. I tried using the program and it crashed. I then tried launching eso.exe directly and it’s now crashing too.

    Here is the error I get when eso.exe crashes:

    Problem signature:
    Problem Event Name:    BEX
    Application Name:    eso.exe
    Application Version:    1.0.0.1
    Application Timestamp:    5437245f
    Fault Module Name:    StackHash_0a9e
    Fault Module Version:    0.0.0.0
    Fault Module Timestamp:    00000000
    Exception Offset:    0084e9c6
    Exception Code:    c0000005
    Exception Data:    00000008
    OS Version:    6.1.7601.2.1.0.256.1
    Locale ID:    1033
    Additional Information 1:    0a9e
    Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
    Additional Information 3:    0a9e
    Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

    • This reply was modified 2 years, 8 months ago by Profile photo of Ignotus Ignotus. Reason: fixed issue, also ask about 3rd person zoom
  14. Profile Photo
    Auldjohn

    Adept

    Total Posts: 139

    Imperial Templar

    The Elder Sages Guild (TESG)

    @Sorien,

    At one point you posted a readme for SweetFX, either in the old TF thread or on your former Mobi site.  I refreshed my download of SweetFX today from your link in this thread. Unfortunately the posted File Dropper SweetFX ZIP does not include the readme. I must have accidentally deleted the readme from my downloads folders.

    Please repost the SweetFX instructions or readme here in this new thread. I forgot where to put the SweetFX files and how to activate it in either ESO or  Skyrim. TIA!

    –Auldjohn, MobiPlus subscriber.

  15. Member Avatar
    Ramasurinen

    Novice

    Total Posts: 21

    Hi Sorien. It looks like the crashes I was experiencing with the launcher were not its fault, though it may have just been bringing them to light. It must have been an nvidia driver vs ESO 1.4 problem as updating to the newest beta drivers has fixed the exception errors completely. It was only happening when using the launcher, but maybe that was just pushing an already unstable game over the edge, dunno. Regardless it’s been working perfectly for almost a week now, not a single error. Yay!

     

    Cheers.

  16. Profile Photo
    Vizier

    Scamp

    Total Posts: 2

    Just wondering if the mod is still being supported.   ESO is pretty much unplayable for me without an altered FOV.  I see a decide lack of activity in this thread for what I would think is a very popular mod.

  17. Member Avatar
    Thumper

    Scamp

    Total Posts: 7

    Looks like update 5 has gorfed the launcher again.  :( @sorien

    I get the following error:

    There was an error modifying the game, the game will  be loaded normally.

    Patch Error #:3, Hook Error true

    Its like I have cataracts now. :(  If I look down my feet are foggy.  Ok, not quite, but close.

  18. Profile Photo
    xMovingTarget

    Apprentice

    Total Posts: 32

    Dunmer Dragonknight

    Hodor

    Getting dizzy because the standard FoV ! Need update ;)

  19. Member Avatar
    Ariannona

    Novice

    Total Posts: 17

    Khajiit Nightblade

    Can confirm, newest patch brought Error code

     

    There was an error modifying the game, the game will  be loaded normally.

    Patch Error #:3, Hook Error true

  20. Profile Photo
    Sorien

    Adept

    Total Posts: 242

    Ill fix it later today… I haven’t slept yet.

Reply To "Hook64 (Previously ESO Launcher)"

You are not currently logged in. You must log in before replying to this topic.